Is your Plesk update getting failed in Ubuntu? We can help you with the update.

Plesk control panel is an optimal solution for web hosting business. It provides a simple and easy to use interface to manage the server.

At Bobcares, we often get requests to solve problems related to Plesk as a part of our Server Management Services.

Today, let’s analyze the cause and see how our Support Team fix the Plesk update error.

 

Why does Plesk update fails?

Many of our customers use Plesk because of its simple interface. However, errors are not free from this leading web hosting control panel.

One such error is received while updating the Plesk.

We’ve seen in most of the cases the Plesk fails to update due to outdated OS and missing micro-updates.

 

How we fix Plesk update failed error in ubuntu?

Mostly, shared hostings are not Ubuntu but some of our clients with VPS are having it as well. As a result, we fix errors like Failed to update Plesk in ubuntu for our clients.

Recently, one of our clients was having this error. He contacted us with the below error message while upgrading Plesk.

ERROR: Installation will not continue
The apg-get failed with the following message:
Reading package lists...
Building dependency tree...
Reading state information...
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
aum : Depends: libapache2-mod-security2 but it is not installed
Not all packages were installed.
Please contact product technical support.

Let’s see how our Support Engineers fix this error.

 

1. Outdated OS

The client was using Ubuntu 14.04.6 LTS‬. Ubuntu 14.04.6 LTS support has ended on April 2019. They do not provide standard support for this OS anymore.

Solution: We asked the client to update the OS. After that, we suggested him to install the Mod-Security module from the Plesk panel. Therefore, the Plesk update started successfully.

 

2. Missing micro-updates

We normally see the below error message in the Plesk Control Panel.

Plesk update failed in ubuntu

 

This is because of some missing micro-updates.

Solution: We can update it via Tools & Settings > Updates and Upgrades. We can also do it from the command line using the below command.

plesk installer --select-release-current --upgrade-installed-components --reinstall-patch

 

3. Missing Dependencies

In some cases, the Plesk update fails due to missing Dependencies. Recently, one of our customers approached us telling us that his Plesk was not updated and received an error while updating it.

Solution: He was using Ubuntu server. So we ran the below command to fix this error.

apt-get -f install

Then we used the Plesk Repair Tool to repair the installation of updates with the below command.

plesk repair installation -y -v

 

[Having trouble in fixing Plesk errors? – We’ll fix it for you.]

 

Conclusion

In short, the error Plesk update failed in ubuntu happens due to outdated OS and missing micro-updates. Today, we saw how our Support Engineers fix errors related to the Plesk update.



Source link

Author

Write A Comment